Pinzi SSI

Engine troubles? Try here.
GRCameron
United States of America
Posts: 158
Joined: Tue May 27, 2014 7:32 pm
Location: Yarnell, AZ

Re: Pinzi SSI

Post by GRCameron » Sat Oct 31, 2015 12:24 pm

With this auxiliary 12v alternator, don't you also need a separate 12v battery to go with it? If you try and connect it to one of the batteries in the 24v series string, that battery will always be at a different charge level than the other. Without the extra battery you couldn't start the vehicle due to no primary voltage at the SSI. No battery also means no voltage regulation for that circuit - alternators with internal regulators will float high without a battery.
George Cameron
Yarnell, AZ
1979 Pinz 710M
Molon Labe

User avatar
edzz
United States of America
Posts: 1305
Joined: Tue Aug 11, 2009 12:13 am
Location: Coeur d'Alene, ID

Re: Pinzi SSI

Post by edzz » Sat Oct 31, 2015 9:00 pm

GRCameron wrote:With this auxiliary 12v alternator, don't you also need a separate 12v battery to go with it? If you try and connect it to one of the batteries in the 24v series string, that battery will always be at a different charge level than the other. Without the extra battery you couldn't start the vehicle due to no primary voltage at the SSI. No battery also means no voltage regulation for that circuit - alternators with internal regulators will float high without a battery.

Yes additional battery (or battery's) required. This auxiliary alternator is used to provide power for a separate 12v system. This system would not have anything common to the 24v system other than the ground (frame).
Cum catapultae proscriptae erunt tum soli proscript catapultas habebunt.

User avatar
Hotzenplotz
Austria
Posts: 294
Joined: Wed Jan 18, 2012 9:07 am
Location: Vienna, Austria

Re: Pinzi SSI

Post by Hotzenplotz » Sun Nov 01, 2015 3:01 am

GRCameron wrote: This system would not have anything common to the 24v system other than the ground (frame).
yes, but ...

I suggest to connect the minus connector of the 12 v and the "lower" of the two 24 v batteries together.
This results in getting the ground connection for both circuits (dis-) connected by a single mains switch...
Cheers
Albert
========================
My Pinz has NEVER been with any army

User avatar
4x4Pinz
United States of America
Posts: 983
Joined: Sat Oct 24, 2009 6:17 pm
Location: arizona

Re: Pinzi SSI

Post by 4x4Pinz » Sun Nov 01, 2015 3:57 pm

currently my 12v system is charged by my solar system. with the upcoming power steering systems in the works I will have to have a system that can produce more power and reliably. The second smaller alternator should do the trick nicely. As for disconnecting both systems at once, this would not work for me. Once my truck is at its destination I turn off the main power switch but still use all my accessory 12v items (fridge,lights, tv, swamp cooler....) I don't like leaving my main switch on as it does have a drain on the 24v system and it is no fun to switch your convenience batteries with your main truck batteries.

pinzinator
Posts: 791
Joined: Thu Jul 29, 2004 3:12 pm
Location: Indio, California

Re: Pinzi SSI

Post by pinzinator » Wed Nov 11, 2015 8:07 pm

Out of stock until December, sorry.

User avatar
GenevaPinz
Switzerland
Posts: 516
Joined: Fri Feb 22, 2008 12:00 pm
Location: near Geneva, Switzerland
Contact:

Re: Pinzi SSI

Post by GenevaPinz » Sat Nov 14, 2015 12:42 pm

Just finished installing mine today. The fact that I could do it on my own is testimony to the fact that this requires very limited knowledge (I did learn in the process that it helps to get the gearbox in neutral before cranking the engine by hand...):-)!! After setting the timing again the engine started right away.

The kit contains everything needed, down to zip ties and electrical connectors, and the instructions are really detailed and step-by-step. It has been obviously thought through and it shows. I deviated from instructions to add a ground wire on the coil support plate. Instead of adding a screw through the truck's sheetmetal, I extended the wire about a foot and a half to the body grounding strap, just outside the battery box.

The only point that I checked and re-checked without being 100% happy is how close the throttle command rod is to the coils connector, but I guess I am worrying for nothing as it seems nobody reverted saying this is an issue.

I haven't done a test drive like I wanted yet, as I was out of daylight by the time I finished, but I will tomorrow.

Thanks a lot for designing this and selling it as a kit, this is quite an improvement over the stock setup.
Jan

'72 Pinzgauer 710M

User avatar
pcolette
United States of America
Posts: 1418
Joined: Sun Dec 10, 2006 7:38 pm
Location: Southwest Wisconsin

Re: Pinzi SSI

Post by pcolette » Sat Nov 14, 2015 1:37 pm

GenevaPinz wrote:The only point that I checked and re-checked without being 100% happy is how close the throttle command rod is to the coils connector, but I guess I am worrying for nothing as it seems nobody reverted saying this is an issue..
I had the same concern (probably needlessly) so I covered the throttle rod with some plastic split loom that just sort of floats on the rod. Besides acting as an insulator I'm also hoping it prevents any chafing with the various wires. (note: I made my own spark plug wires for reasons unclear to me at this point :? )
IMG_2548.jpg
IMG_2548.jpg (117.04 KiB) Viewed 3597 times
Paul C.
_________
'73 Swiss 710M
'89 Puch 230GE
2002 MB G500 (For Sale)

User avatar
GenevaPinz
Switzerland
Posts: 516
Joined: Fri Feb 22, 2008 12:00 pm
Location: near Geneva, Switzerland
Contact:

Re: Pinzi SSI

Post by GenevaPinz » Mon Nov 16, 2015 4:19 am

I put a layer of duct tape on top of the connector to shield it somehow, and I will keep an eye on it for any abrasion from the throttle rod.
After realising that I had put the doghouse and seats back without re-plugging the coils (it turns out you can put the plug back in from below... :roll: ), I could go on a short test drive. The idle is much steadier and the truck just performs better accross the whole rpm range.
Great modification, very simple to install and highly effective!
Jan

'72 Pinzgauer 710M

gorsko
Posts: 18
Joined: Tue Dec 02, 2014 4:44 am
Location: Gorsko Kalugerovo, Central Bulgaria
Contact:

Re: Pinzi SSI

Post by gorsko » Mon Nov 16, 2015 10:54 am

I've also joined the band of converts to PinzSSI.
Installation is a breeze, setting the timing was (for me) a "right-first-time" effort. As I've also rebuilt the carbs, and the motor's not been run in months, I cranked for a bit to get oil pressure and gas into the carbs before I fitted the plugs. I didn't expect great things because the carbs weren't balanced or adjusted, but it fired right up first time and settled down to a steady idle immediately, completely unlike the usual 5 minutes of spitting and fluffing ...
I took extra time to solder all connections rather than just crimp them while installing, because most of the connections I look at on the truck are a bit corroded, probably as a result of standing outside in all types of Bulgarian weather before I found it! Hopefully the following links will show a bit of the installation and the improved running! Thanks to all forum members for the inspiration!
https://goo.gl/photos/Rh5mrUor7U9XVtVm8
https://goo.gl/photos/gemQ4iBTAnn8nwSy7
https://youtu.be/JkNFYzd1iWk
1975 712M (AMB)
1993 Defender 90 (200TDi)
1985 Uaz 469B
1982 Luaz 969 "the Russian Haflinger"

kdiqq
United States of America
Posts: 268
Joined: Tue May 26, 2015 3:30 pm
Location: Houston, TX

Re: Pinzi SSI

Post by kdiqq » Sun Nov 22, 2015 8:16 am

Has anyone done this on an Austrian pinz? After looking at this picture I realize my seat belt mount sits right next to where the coils are.. Worried that they will hit.
1977 Austrian 710M

User avatar
John L
Posts: 160
Joined: Thu Sep 15, 2011 7:48 am
Location: Covington, Louisiana

Re: Pinzi SSI

Post by John L » Tue Dec 29, 2015 10:46 am

Just ordered my kit. One of my resolutions is to have a smooth running Pinz for the New Year! If I can install it without too much trouble then it will be a New Years miracle. :) Glad there was so much chatter about this system. I was torn between replacing the Petronix or going with the Pinz SSI. Hopefully I made the right decision. I'll keep you guys posted.

JL

User avatar
19D20
Posts: 68
Joined: Sun Oct 09, 2011 7:00 pm
Location: Texas

Re: Pinzi SSI

Post by 19D20 » Thu Dec 31, 2015 8:56 pm

Best mod you can do for the money, easy to install and great customer support.
I failed to tighten the screws on the cap on the module and lost it. I was promptly sent another one gratis.
I also had a grounding issue and was told how to fix it by phone and e mail in a timely manner. Thanks Rick !

User avatar
John L
Posts: 160
Joined: Thu Sep 15, 2011 7:48 am
Location: Covington, Louisiana

Re: Pinzi SSI

Post by John L » Mon Jan 04, 2016 10:12 am

Guys I need to tap into your knowledge base... I ordered and received the SSI kit. Rick has been great to deal with. I had some trouble getting the old distributor out. (is this normal? It wouldn't even rotate much less come out>) It finally broke free after 40 years of being there and I oiled the shaft of the SSI unit, made sure I had the gear lined up with the dog on the engine, and then installed the unit. I thought it was seated all the way down... Anyway, I installed the rest of the kit according to the instructions. I then went to set the timing. I put the engine at TDC, adjusted the line on the disc so the light came on, then proceeded to rotate the engine to test the timing. What I realized was that as the engine was rotating but the timing disc was not. Rick figures I didn't have the unit seated properly. So, after struggling a bit, I was able to remove the unit, line it up properly and re-seat it. I was of the impression this was a simple drop in item; but for some reason the old one coming out was super tight as well as the shaft on the new unit going in. So the unit went all the way down to the lip on the shaft meaning it won't go down any further. It hits the clamp. I went through the process of setting the timing again. Got it to TDC, adjusted the disc so the light was on, then as I rotated the engine the timing disc would rotate sometimes, but not all the time the engine was rotating. Also, something I noticed was my belt was slipping... I can rotate the fan, the belt will rotate, but the engine won't unless I put some added tension on the belt. (Don't know if this is a separate problem that needs to be handled in order to get the timing right). One other thing is I am using a large spanner wrench as I don't have a 27 mm socket. Don't know if that is significant.

I'm basically ready to install plugs, wires and roll; but need to get the timing set. Thoughts on what might be the problem??? Any suggestions would be greatly appreciated.

John

User avatar
audiocontr
United States of America
Posts: 1827
Joined: Fri May 01, 2009 1:30 pm
Location: Detroit Motor City

Re: Pinzi SSI

Post by audiocontr » Mon Jan 04, 2016 2:22 pm

I thought the keyed portion of the distributor shaft is offset. It can only go on one way. I could see how it may catch and rotate occasionally if it were 180 degrees off, but something is telling me that the original distributor base broke off and is still down there. Have you looked down into the distributor shaft hole?

I recommend cleaning/oiling the hole as well. Maybe with an emory cloth?
1973 712m
(2) 1968 Haflingers 1 For Sale
1978 GMC Palm Beach
1979 Mini Ranger For Sale
1986 Corvette For Sale
2001 F250 Diesel and trailer
Company Cars
2019 Expedition
2019 F-150

User avatar
Haf-e
United States of America
Posts: 822
Joined: Thu Oct 06, 2011 5:25 pm
Location: Mount Vernon WA USA

Re: Pinzi SSI

Post by Haf-e » Mon Jan 04, 2016 3:05 pm

I would put the two distributor shafts side by side and see what the difference is - maybe post some pictures of it? Its always possible a dimensions was off in the machining - it wouldn't take much to cause a problem like you describe. The shaft and bottom wobbly part should look virtually identical.

Can't really imagine much else down there can cause the problem - sounds like a tolerance issue?
Haf-e

1971 Pinzgauer 710M

Image
Disc Brake Conversion Kits for 710 and 712 Pinzgauers
www.klugewerks.com

Post Reply