Backfired and Died

Issues pertaining to the TGB/C30X series engine and driveline issues
Post Reply
mjfreshyfresh
Posts: 36
Joined: Sun Oct 27, 2013 4:21 pm

Backfired and Died

Post by mjfreshyfresh » Sun Jun 07, 2015 9:36 pm

Had an great 150 mile trip out in the Cascade range. This morning it was running really rough at 1k rpm, higher rpms were better. Small backfires here and there. The trip home was tough because if I had to stop it would had a hard time getting going had to feather the gas.

One mile from home the C303 let off a massive backfire and died. Wouldn't start again. Towed it the rest of the way.

I had an old 76 Westy that would sometimes backfire and blow a vacuum hose off then it wouldn't start. This seems similar but I can't find a hose that's out of place.

Any ideas?

Thanks-
MJ

User avatar
pcolette
United States of America
Posts: 1392
Joined: Sun Dec 10, 2006 7:38 pm
Location: Southwest Wisconsin

Re: Backfired and Died

Post by pcolette » Sun Jun 07, 2015 10:42 pm

I'm not familiar with the Volvo but I had a similar problem on another vehicle and it turned out that the distributor adjustment clamp had loosened and changed the timing to where it wouldn't run. Might be worth a look.
Paul C.
_________
'73 Swiss 710M
'89 Puch 230GE
2002 MB G500 (For Sale)

mjfreshyfresh
Posts: 36
Joined: Sun Oct 27, 2013 4:21 pm

Re: Backfired and Died

Post by mjfreshyfresh » Sun Jun 07, 2015 11:53 pm

Thanks Paul. I checked the distributor and it seems to be in order. I should read up on timing with a Volvo.

User avatar
VinceAtReal4x4s
Admin
United States of America
Posts: 1614
Joined: Mon Apr 12, 2004 10:36 pm
Location: Ca. or lost in South West USA
Contact:

Re: Backfired and Died

Post by VinceAtReal4x4s » Mon Jun 08, 2015 1:16 am

Did you look in the cap? Check points? I'd put a timing light on it and see where that is which will help narrow things down to dist. or cam/timing issues.
"For those who risk, life has a flavor the protected shall never enjoy"

Real4x4 Facebook https://www.facebook.com/real4x4s

Image

Uli-RT
Germany
Posts: 59
Joined: Wed May 16, 2012 7:27 am
Location: Baden-Württemberg

Re: Backfired and Died

Post by Uli-RT » Mon Jun 08, 2015 3:02 pm

... check ignition coil.

aclark79
United States of America
Posts: 124
Joined: Wed Aug 06, 2014 7:06 am
Location: Portland Oregon

Re: Backfired and Died

Post by aclark79 » Wed Jun 10, 2015 12:39 am

Any updates?

dokatd
United States of America
Posts: 207
Joined: Sun Nov 30, 2008 8:13 pm

Re: Backfired and Died

Post by dokatd » Sun Jun 14, 2015 10:22 am

VinceAtReal4x4s wrote:Did you look in the cap? Check points? I'd put a timing light on it and see where that is which will help narrow things down to dist. or cam/timing issues.

Hard to put a timing light on an engine that does not run. Static timing the dist is very easy on the Volvo though. Set static to 10*.

I would clean all ignition connections as the tend to corrode and cause the truck to act up a bit.
Also, the ballast resistor can ruin your day as well.

Things to check

All ignition connections
Static timing
Ballast resistor
Coil resistance
Condenser
Points
Cap and rotor
Ground connections

Alternate if the above check out
Fuel filter
Try spraying carb cleaner in the air filter and see if the truck will start and run. If so you have a fuel issue not an ignition issue.

The above is not a comprehensive list but should set you in the right direction or directions. To me it does not sound like you have an internal part failing, it seems to be more ignition or fuel related at the moment.

Good luck

jeepboy_90
Posts: 36
Joined: Wed Jul 30, 2014 12:01 am
Location: Northern California

Re: Backfired and Died

Post by jeepboy_90 » Mon Jun 15, 2015 9:12 am

Not to highjack MJ's post, but I am going to do a little tuning on my B30 this week.

Timing seems off, what is the starting point. (10 degrees advanced?)

Plug gap? Im running a Pertronix and upgraded coil.

Plug recommendations?

Have a great week. MJ hope you got your issues fixed.

dokatd
United States of America
Posts: 207
Joined: Sun Nov 30, 2008 8:13 pm

Re: Backfired and Died

Post by dokatd » Mon Jun 15, 2015 9:22 pm

jeepboy_90 wrote:Not to highjack MJ's post, but I am going to do a little tuning on my B30 this week.

Timing seems off, what is the starting point. (10 degrees advanced?)

Plug gap? Im running a Pertronix and upgraded coil.

Plug recommendations?

Have a great week. MJ hope you got your issues fixed.
Base timing is 10* if all is working right in the dist this will set your total advance pretty close to spec. I'm not much help on the other items as they are more preference and based on which plugs you want to use.

mjfreshyfresh
Posts: 36
Joined: Sun Oct 27, 2013 4:21 pm

Re: Backfired and Died

Post by mjfreshyfresh » Sat Jul 11, 2015 1:27 pm

Hey Guys-

Just wanted to follow up on this thread...

Three things got me:
* bad timing, very bad, terrible!
* bad points, worthless!
* sporadic vacuum leak on my carbs

So timing is now all set, points are all set and I switched from Strombergs to SU's. Things are running very well now. Did a 7 day trip up through the Northern Cascades almost to Canada. Caught the NW Overland Rally on the way, here are some pics: https://medium.com/overland-exploration ... ec390e93cf

Thanks for all the great info and help!

Cheers-
MJ

aclark79
United States of America
Posts: 124
Joined: Wed Aug 06, 2014 7:06 am
Location: Portland Oregon

Re: Backfired and Died

Post by aclark79 » Mon Jul 13, 2015 2:47 am

Glad to hear it! I plan on bringing the TGB over and hopefully we can crawl all over it and see if it suffers from any of the same issues.

The pictures look great, any more of you're rig and your camping set up?

August 9th it arrives, can't wait to drive it down from Tacoma.

aclark79
United States of America
Posts: 124
Joined: Wed Aug 06, 2014 7:06 am
Location: Portland Oregon

Re: Backfired and Died

Post by aclark79 » Fri Jul 17, 2015 5:08 am

Image

mjfreshyfresh
Posts: 36
Joined: Sun Oct 27, 2013 4:21 pm

Re: Backfired and Died

Post by mjfreshyfresh » Fri Jul 17, 2015 10:36 am

Nice! Where did you find that pic? I see it's got a logo on the bottom right?

BTW: Officially named my Volvo "Hotbox" a nod to it's firefighting heritage, boxy shape and lack of AC. Logos coming...

aclark79
United States of America
Posts: 124
Joined: Wed Aug 06, 2014 7:06 am
Location: Portland Oregon

Re: Backfired and Died

Post by aclark79 » Fri Jul 17, 2015 11:10 am

It was on Tacoma World forum, someone had a thread from the event.

Post Reply