Engine temperature sensor - has anyone added one?

Engine troubles? Try here.
User avatar
rmel
United States of America
Posts: 1142
Joined: Sun Sep 25, 2011 12:19 pm
Location: Woodside, CA
Contact:

Re: Engine temperature sensor - has anyone added one?

Post by rmel » Thu May 28, 2020 10:36 am

Couple of comments in general.

First placement of add-on sensors in the Pinz, be it O2, Oil Temp/Pressure, MAP, EGT/pyrometer, etc.
will always be a compromise. Your retro-fitting a capability that simply was not designed in at the
get-go. So unless your planning on a major redesign it's gonna be a compromise and less than perfect.

Starting with O2 sensor, the compromise I made was placement on header for #2 and #3 - thus the average
O2 in the stream of 2 out of 4 cylinders. If you want the average of all 4 cylinders you would need to
redesign the hard coupling to merge both headers. With the trade-off I have it seems to be good enough.
I adjust ARF on the fly with my EFI controller setting to ~11:1 for peak torque for the trail, and to 13.5:1
for good fuel economy on the HWY -- the results are very noticeable. So I'd say it's in the ballpark despite
the trade-off. If I run ~ 10:1 you can smell your running too rich, and if I run closed-loop (not recommended)
at 14.5:1 it's just too lean. Is it perfect no. You do have to develop an experience base to mentally
recalibrate the readings to some degree.

The same is true for EGT, it's going to be a trade-off. Pick a spot close to the exhaust port, but more
important be consistent with placement of all 4 so you get a better relative reading between each. The
absolute value will not be 100% accurate. But what I find of value is the behavior, how they ramp in
value, if my experience of the hottest (#3) goes higher than expected does the driving conditions and
outside temp explain that or is there a problem. It's a quick way to know when you have a spark problem
on a given cylinder :P , or more unnerving, a cold laggard cylinder due to valve seat recession -- I had
that problem once -- was time for heads to be refurb. I see this as vital signs with with an experience base
that tells you a lot about the relative health of the engine. On my 712 I decided to go for only one EGT
on #3 the most notorious cylinder out of the bunch to watch.

Oil temp and pressure is more deterministic. You have one tapped hole to decide which way to go.
Pressure or Temperature. The stock pressure switch is better than nothing but it's basically an idiot
light. My 710 does have both T&P with an added drilled and tapped sensor port. I don't feel like going
that route yet on the 712. So I have to decide which is more important full range Pressure or Temp.
There are interposers that fit between the Oil filter and the base housing. Seems to have sufficient
clearance to get one in there. I might one a try if I can find one with 1"-12 thread, this is an example
of one I found but only 3/4" thread.
https://prosportgauges.com/products/oil ... 0851944588
Last edited by rmel on Thu Jun 04, 2020 3:55 pm, edited 1 time in total.
Puller: 71' 710K 2.7L EFI aka Mozo
Follower: Sankey MK 3, 3/4 Tonne
Rescue Pinz: 73' 712M

Driver: Ron // KO0Q

one2many
Australia
Posts: 177
Joined: Sun Dec 22, 2013 5:53 pm
Location: Melbourne Australia

Re: Engine temperature sensor - has anyone added one?

Post by one2many » Thu May 28, 2020 11:23 pm

RMEL I agree with all you pointed out.
I should have been more clear about my oil pressure, the “idiot light” as you described it is just that...not a sufficient indicator of ACTUAL oil pressure. I am referring to a VDO dash mounted oil pressure gauge which I use in conjunction with my oil temp gauge (Also VDO).
I’m a little envious of your EFI as I’m still running carbs and for my LPG a basic vapourizer feeding a mixer system (not a mixer ring above carb) however my AFR settings are pretty close to what you describe for your EFI setup. I have managed to achieve about 12.3 to 12.5 for maximum torque like hill climbing and on the trails. Then when I’m just in a cruise application I’m running approximately 14.5 to 14.7, same principle but I’m just running a little leaner than you are. One important note is that I’m not using any processor or ECU of any kid...totally mechanical. I’ve used both the Impco vapourizer feeding an Impco mixer, a 225 but I’d consider using a 200 mixer with the larger 67mm intake & exit outlets as I have reason to believe some further fine tuning would be more easily achieved. The other system I’ve used and quite like is the BRC vapourizer feeding a BRC BLOS mixer. Both systems work very well with the Pinzgauer engine but my preference would be the BLOS mixer because it has less air restriction as the air can pass straight through it as opposed to going Around a diaphragm once its been lifted by the engines vacuum (or lack of vacuum).
1985 pinzgauer 712K factory 2.7lt civilian (RHD, 4 door K)
1979 Volvo tgb 1314a (under construction to om606 diesel/722.6 trans. Dual cab/tray)

User avatar
rmel
United States of America
Posts: 1142
Joined: Sun Sep 25, 2011 12:19 pm
Location: Woodside, CA
Contact:

Re: Engine temperature sensor - has anyone added one?

Post by rmel » Fri May 29, 2020 9:21 am

one2many,

That's a mighty interesting setup you have there. I have read some of
your prior postings on the conversion. I've wondered about the relative
power output given there's about 20% less Btu/gal for LPG versus Gas.
Puller: 71' 710K 2.7L EFI aka Mozo
Follower: Sankey MK 3, 3/4 Tonne
Rescue Pinz: 73' 712M

Driver: Ron // KO0Q

one2many
Australia
Posts: 177
Joined: Sun Dec 22, 2013 5:53 pm
Location: Melbourne Australia

Re: Engine temperature sensor - has anyone added one?

Post by one2many » Sat May 30, 2020 4:11 am

RMEL given the minimum octane ratings of LPG Australia is minimum 110 but generally around the 130-140 mark if bought from welding gas suppliers like Supagas or BOC, etc. but 90% of our service stations all have lpg pumps right next to the diesel and petrol. So availability isn’t a problem. Given the extra octane ratings I notice a slight increase in torque especially on long hill climbs...when on petrol a long hill can slow me down from 100km to 60kmh. With LPG if I’m travelling along at 100km per hr (62mph) then start to climb a long hill the 712k slows to 80km per hr. Obviously ignition timing has everything to do with this so I tend to run a compromise of 8* BTDC, LPG runs better again at 10* BTDC but petrol starts ping ever so slightly above the 8* BTDC mark. However it’s VERY hard to hear given the noise of the engine...this testing can only be done without the engine cover on. During tests with the engine cover on I’ve advanced as far as 16* BTDC and I couldn’t hear the pinging while running on petrol. Note this was for testing purposes only I’d never run 16* BTDC under normal operating conditions.
Because I have a dual fuel setup and need to find a happy compromise between the two fuels (8* BTDC) I only use the highest octane petrol available in Australia which is 98octane, not including avgas which isn’t available in the high country. I can get it at smaller airports and drag strips, raceways etc...major PITA.
In short and in my experience more torque can be achieved from LPG only IF the ignition timing is set to take advantage of the extra octane available from LPG. As usual there are other factors to consider like... once I fitted my Pinzi SSI LPG performance (torque) improved by at least 10% possibly more. Another important factor when running LPG is running a cooler heat range spark plug also has quite a dramatic effect on the LPG side but I honestly can’t notice any difference on the petrol side with the cooler heat range plug. LPG burns hotter so changing to a cooler plug heat range helps considerably. If I remember correctly I’m using NGK Resistor plugs BR7es (colder) as opposed to the NGK BPR6es which are standard heat range, the difference is only noticeable on LPG.
A58DCC86-FD19-4D12-B08E-91FDF0FC7F7C.jpeg
A58DCC86-FD19-4D12-B08E-91FDF0FC7F7C.jpeg (102.21 KiB) Viewed 559 times
This is the PPI LPG TANK I ordered from New Zealand, it’s completely certified in all major countries. Mine hold 140lts of LPG (still have the standard larger “ambulance style” petrol tank on the RHS So my range is awesome (my Civi 712K is a rare 4 door). It was ordered without the rear RHS passenger door so there is no footwell to intrude on the larger tank unlike 5 door 712k’s
This LPG tank measures 1350mm x 850mm IIRC. I had it made to fit inside the rear footwell/nato pallet section but left it a little short so I had some room for water storage and possibly a generator. PPI can make thes tanks to any dimensions required, I’ve mounted mine so that the sliding drawers sit exactly level with the wheel arch inside the rear of the vehicle, so if We chose to sleep back there a queen size mattress fits very comfortably.
I’ve been running the LPG/dual fuel set up for approximately 6 years now and done about 60,000km with 80% of that driving done on LPG, upper cyl lubricant is a must IMO on either fuels since they stopped adding lead to petrol in the mid 80’s. Without this you will see valve seat recession on petrol or LPG.
Sorry for the over explained post but it can be complex for some to get good understanding of what I’ve achieved.
In Australia dual fuel setups have been common since the 1980’s and LPG has always been at least half the price of petrol and available anywhere petrol and diesel is, for this reason these setups are not only very well understood by the average mechanic but it makes sense to utilise them where possible. This may not be the case in the USA.
Thanks to Rick for his pinzi SSI...the multispark capability’s of that ignition coupled with a much hotter spark is what made the LPG come to life and add 10%-15% more torque on that fuel. On petrol I reckon I’ve seen a minimum of a 5% gain in torque. It just holds its own on the long hill climbs and I can even overtake semi trailers now.
1985 pinzgauer 712K factory 2.7lt civilian (RHD, 4 door K)
1979 Volvo tgb 1314a (under construction to om606 diesel/722.6 trans. Dual cab/tray)

one2many
Australia
Posts: 177
Joined: Sun Dec 22, 2013 5:53 pm
Location: Melbourne Australia

Re: Engine temperature sensor - has anyone added one?

Post by one2many » Sat May 30, 2020 4:49 am

6C6AF70F-4365-4D3A-A180-7AF2E43435DA.jpeg
6C6AF70F-4365-4D3A-A180-7AF2E43435DA.jpeg (896.78 KiB) Viewed 558 times
Just one more thing...pictured is my old ignition (now comes with as spare).
It was by no means a cheap or bad ignition in any way, it’s just that the SSI is far superior by having a strong multi sparked ignition all the fuel is getting burnt on each compression stroke instead of burning most the air fuel mixture and sending the unburnt fuel out the exhaust valves. It’s a no brainer...MSD ignitions increase torque and ignite more of the combustion chamber gasses therefore wasting less. The is equivalent to more torque for better economy and is the reason why race teams have been using MSD ignitions for the last 30 odd years. It’s a well documented easy way of increasing any combustion engines performance.

The ignition above is just an early VW ignition converted from points to electronic (Hall effect), the module (box thing) mounted inside the cab and therefore I was never able to drown it.
It was always reliable and performed as well as any 1980’s (if not better) electronic ignition. Scorpion ignitions from NSW, Sydney Australia built it approx 20-25 years ago and they are still in business. However when I enquired about a spare module for peace of mind his quote on this part alone was more than Ricks Pinzi SSI UNITS and gave me the MSD capability that my old one did not. Cheers Rick.
Rick if you happen to read this I’d be interested in a version 1 switchable advance curve unit as my dual fuel set up may benefit from this, if you have any old ones lying around let me know...I’ve been meaning to contact you via your website but never seem to Find the time. Cheers.
1985 pinzgauer 712K factory 2.7lt civilian (RHD, 4 door K)
1979 Volvo tgb 1314a (under construction to om606 diesel/722.6 trans. Dual cab/tray)

User avatar
rmel
United States of America
Posts: 1142
Joined: Sun Sep 25, 2011 12:19 pm
Location: Woodside, CA
Contact:

Re: Engine temperature sensor - has anyone added one?

Post by rmel » Sat May 30, 2020 10:29 am

one2many, we may have committed a mortal sin by taking this someone off topic :shock: :wink:

Well darn good point w.r.t. Octane comparison and looks like you are well tuned and taking good
advantage of that -- very IMPRESSIVE results. I suspect your engine does not "stumble" runs smooth
even at low RPM. Must be great crawling over obstacles with better torque and smoother running.
Puller: 71' 710K 2.7L EFI aka Mozo
Follower: Sankey MK 3, 3/4 Tonne
Rescue Pinz: 73' 712M

Driver: Ron // KO0Q

one2many
Australia
Posts: 177
Joined: Sun Dec 22, 2013 5:53 pm
Location: Melbourne Australia

Re: Engine temperature sensor - has anyone added one?

Post by one2many » Sat May 30, 2020 11:56 am

True on both counts perhaps we should start a new thread and yes the LPG runs much smoother without any stumbles off idle and climbing in low 1 requires almost no throttle control, it just idles up and over most obstacles.
But I’m sure your EFI performs in the same way.
Have you looked at the LPG injection kits? Fairly inexpensive by comparison and they inject the LPG in liquid form (high pressure) without the use of any mixer system, only a vapourizer and injector rail mounted pretty much anywhere and fed to the inlet manifold via high pressure fuel lines so no drilling and welding into the intake runners. The best part of these systems are the LPG is very very cold, verging on freezing meaning the combustion chamber fills with much more fuel mixture because colder mixture is contracted versus hot mixture/air is expanded.
If you already have petrol EFI this type of system would be well worth looking into. You will see them all over google maybe even eBay...quite popular in Europe I believe. Just food for thought.
The other great thing I love about dual fuel systems are the extra point of reliability, should one system fail on the trails....just finish your trip on other fuel system. Carbs are always the fuel system I worry most about, nothing much to go wrong with mechanical LPG.
Perhaps Vince can move our conversation to a new thread.
Cheers
1985 pinzgauer 712K factory 2.7lt civilian (RHD, 4 door K)
1979 Volvo tgb 1314a (under construction to om606 diesel/722.6 trans. Dual cab/tray)

User avatar
rmel
United States of America
Posts: 1142
Joined: Sun Sep 25, 2011 12:19 pm
Location: Woodside, CA
Contact:

Re: Engine temperature sensor - has anyone added one?

Post by rmel » Sat May 30, 2020 12:02 pm

Well EFI does help, but there's still some degree of stumbling.
I run with high Octane, well I should say higher Octane, with
91 typically at the pump in Cali. As far as LNG (Autogas) -- it's
just not readily available. Ironically the US is an exporter though.
Puller: 71' 710K 2.7L EFI aka Mozo
Follower: Sankey MK 3, 3/4 Tonne
Rescue Pinz: 73' 712M

Driver: Ron // KO0Q

one2many
Australia
Posts: 177
Joined: Sun Dec 22, 2013 5:53 pm
Location: Melbourne Australia

Re: Engine temperature sensor - has anyone added one?

Post by one2many » Sat May 30, 2020 4:52 pm

Oz is also an exporter...we sell it all to China for a pittance (maybe 3cents per litre?) they process it and sell it back to us for I think around 40 cents per litre...it costs about 65 to 70 cents per litre at the pump. It’s just what we economic democracies do...I don’t understand why we don’t look to the Scandinavian type social nationalism models, privatisation of assets only encourages greater social divisions. Nationalising a countries assets stops these divides from growing.
With petrol 91oct is our lowest available, we call it mower fuel and car guys just wouldn’t use it...smells like varnish after sitting in a tank for a week or two, Algae likes growing in too. Next up is 95oct this is what most people use who care at all about their vehicles, chainsaws etc. then there’s the higher 98oct which anyone that has an engine with a compression ratio of 10:1 or higher must use unless they don’t mind their engines pinging. All 4 of these fuels are readily available everywhere, so perhaps we’re spoiled here. There are a few Shell service stations that have a 100oct product but it’s only in the CBD. Since ethanol fuels have become popular many more servos have a 100 octane ethanol fuel available. Since rebuilding some of my carburettors with ethanol friendly rebuild kits I’ve started to use it in those vehicles and I’m slowly becoming a fan of it. I haven’t used it in my pinz yet and I’m not sure that I will...I don’t know if the EI carb rebuild kits I have are ethanol friendly, if not I’ll find a Porsche or VW kit that is or source mu own o-rings and plunger piston ring that are.
Oz recently did a new deal with China regarding our CNG (compressed natural gas) and we got #*!!ed in that deal, I only hope it doesn’t affect the automotive LPG. CNG works well in vehicles too but because it’s compressed the tanks filled are basically heavy wall welding gas bottles like argon or acetylene...not very lightweight. Fill time is about 5 times longer to.
1985 pinzgauer 712K factory 2.7lt civilian (RHD, 4 door K)
1979 Volvo tgb 1314a (under construction to om606 diesel/722.6 trans. Dual cab/tray)

User avatar
rmel
United States of America
Posts: 1142
Joined: Sun Sep 25, 2011 12:19 pm
Location: Woodside, CA
Contact:

Re: Engine temperature sensor - has anyone added one?

Post by rmel » Sat May 30, 2020 5:23 pm

Ah!! OZ uses the "RON" system, US uses the "AKI" (anti-knock-index) system for Octane rating.

RON @ 95 = AKI @ 90.
Puller: 71' 710K 2.7L EFI aka Mozo
Follower: Sankey MK 3, 3/4 Tonne
Rescue Pinz: 73' 712M

Driver: Ron // KO0Q

imacky
Posts: 24
Joined: Wed Feb 13, 2008 4:36 pm

Re: Engine temperature sensor - has anyone added one?

Post by imacky » Sun Sep 06, 2020 10:29 pm

After melting my #3 piston, I want to add a temperature sensor to monitor #3 and/or #4. I found a 12MM CHT SENSOR designed for air cooled engines to be attached under an engine bolt or spark plug. Has anyone added this type of sensor or any other?
Yeah I had a CHT pickup under the #2 military spark plug (the recommended placement). Worked well... but are you sure that plug is seated properly over the ring pickup?? There's no way to test the compression with the plug in, obviously. Anyway, it did work for years and the temperature it showed was reasonable, but it seemed iffy having it under the spark plug. I just now had to take it out since I switched to EI's civilian/electronic ignition and the large metal cover on the plug boot did not leave enough room for the pickup.

User avatar
rmel
United States of America
Posts: 1142
Joined: Sun Sep 25, 2011 12:19 pm
Location: Woodside, CA
Contact:

Re: Engine temperature sensor - has anyone added one?

Post by rmel » Mon Sep 07, 2020 10:26 am

Well there's another approach -- Porche 911 style. Head temp is
measured using a sensor screwed into a shallow hole in the head.
I have one of these on my 710 for the ECU/EFI -- Fuel versus Temp. map.

Next time I have the Dog House off I can take a PIX of the location of that
sensor. Typically it's a Bosch.

An alternative plg'n'play would be with aftermarket Gauges e.g.

https://www.autometer.com/2-cyl-head-te ... lsrc=aw.ds
Puller: 71' 710K 2.7L EFI aka Mozo
Follower: Sankey MK 3, 3/4 Tonne
Rescue Pinz: 73' 712M

Driver: Ron // KO0Q

imacky
Posts: 24
Joined: Wed Feb 13, 2008 4:36 pm

Re: Engine temperature sensor - has anyone added one?

Post by imacky » Mon Sep 07, 2020 2:22 pm

Pics of now-removed CHT sensor... if I were doing it again, I would use something else that didn't require the sensor to mount under a spark plug. Surely it's a good place in theory (a hot place on the head), but in practice it's not confidence-inspiring.

Image

Image

Image

Post Reply